WordPress BooShit

  • – mai prost decat 2.8 e doar 2.9
  • – updateuri prea dese. Da, stiu ca trebuie reparate bugurile si gaurile de securitate.
  • – niciun update minor care nu strica ceva incepand cu plugins si terminand cu functionalitatea wordpress in sine
  • devine prea “bloated”, nu ar putea sa puna noile features wordpress intr-un plugin oficial? Mai bine punem din start mai multe chestii de care nu are toata lumea nevoie dar care se pot strica. NU! Asta nu e inovatie!
  • 4 servere centos 5×64, acelasi setup, aceleasi versiuni php (5.2.12), aceleasi setari – pe unul nu mai merge publicarea de articole – eroare aici
  • folosesc wordpress de 4 ani. N-am avut probleme in 3 ani cate am avut incepand cu 2.8
  • pentru unele pluginuri apar 2-3 updateuri pe saptamana (xml sitemap, all in one seo), de parca doar asta as avea de facut (mai ales cand ai cateva zeci de site-uri pe wp)
  • avem 100 de distributii linux, 20 de webservere, 20.000 versiuni php (4.x, 5.1.x, 5.2.x, si in curand 6 etc )  cu 50.000 de setari si modificari, 100.000 scripturi care ruleaza pe ele – ma mir ca mai exista orice compatibilitate intre ele si ca nu se prabusesc toate ca WTC

WTF?! Alternative?

,

21 Responses to WordPress BooShit

  1. Ionut Staicu 12/01/2010 at 1:47 pm #

    Expression engine, drupal, textpattern, typo (grade diferite de complexitate și features).

    Și probabil mai sunt câteva (zeci) cunoscute dintre care ai putea alege. Timp să ai :)

  2. scribu 12/01/2010 at 2:07 pm #

    Legat de update-uri, se lucreaza la o politica mai buna.

    Ti-am raspuns la topic.

  3. Oradeanul 12/01/2010 at 2:20 pm #

    @Ionut: nu vreau sa stau toata ziua sa patchuiesc :)
    @scribu: mersi :D

  4. zoso 12/01/2010 at 4:39 pm #

    cred ca o sa ramanem pe 2.9.x si gata.ca la photoshop. sau acdsee. sau firefox. sau ym.

  5. Tudor Galos 12/01/2010 at 4:42 pm #

    Community Server pe IIS7? Cu Windows Server 2008 R2?

  6. cti97 12/01/2010 at 4:42 pm #

    alternativa cea mai buna – scrii doar html-uri de mana :)) glumesc, evident

  7. Alex Mihăileanu 12/01/2010 at 4:42 pm #

    Bai, sa fiu al naibii, eu n-am avut fix nici o problema. Si n-am un site, am mai multe. Iar 2.9 chiar are features misto. Unul dintre ele, daca vrei, e wp_post_thumbnail. Usureaza nespus munca unui developer de teme wp.
    Legat de pluginuri, cred ca pur si simplu folosesti prea multe :)) Cu cit mai putine (inclusiv update-uri), cu atit mai putine queryuri de mysql, cu atit mai bine :D

  8. Alex Mihăileanu 12/01/2010 at 4:44 pm #

    Ah, apropo de eroarea aia… Tu chiar folosesti auto-update? Eu fac toate update-urile manual, cu overwrite pentru fisiere, cu delete pentru directoare (wp-admin si wp-includes), upload la latest.zip direct de pe desktop, prin File Managerul din CPanel, dezarhivare, mutare directoare tot prin File Manager. Dureaza maximum un minut.
    Autoupdate-ul ala e de rahat de la prima lui versiune si pina in prezent.

  9. Robintel 12/01/2010 at 4:52 pm #

    Joomla! Nu are atâtea brizbrizuri de SEO, dar e stabilă. :)) Bine, nu e chair pentru bloguri.

  10. Oradeanul 12/01/2010 at 5:07 pm #

    @Subiectiv: update din consola unde e posibil. Zici ca n-ai avut probleme dar updaterul e de rahat :)
    Nu folosesc multe plugins.
    @Robintel: no way! :)
    @Tudorg: IIS dar nu cu wordpress :P
    @Zoso: si cu updateurile de securitate ce facem?:)

    Movable Type anyone?

  11. cti97 12/01/2010 at 5:36 pm #

    how about http://pivotx.net/ daca tot facem sugestii neconventionale :)

  12. zoso 12/01/2010 at 7:02 pm #

    oradeanul, htaccess.

  13. Mircea Popescu 12/01/2010 at 7:45 pm #

    Problema ta in cazul asta este ca ai un plugin care re-declara o clasa care intre timp a fost introdusa si in codul de baza.

    N-ar trebui sa fie nici prea dificil de reparat, nici prea dificil de diagnosticat. WordPress nu este o solutie software pentru oamenii care nu-s dispusi sa citeasca cod. Pentru ei exista blogspot si wordpress.com

  14. Bogdan 13/01/2010 at 1:10 am #

    Joomla dar vorba lui Robintel, nu prea e pentru blog-uri iar daca esti obisnuit cu WP, schimbarea in modul de organizare/lucru/etc poate iti poate provoca tulburari psihice.
    Apropo, se asteapta lucruri mari si bune cu Joomla 1.6 :)

    Poate Movable Type..?

  15. InterAnime 13/01/2010 at 9:28 am #

    [url=http://e107.org/news.php]e107[/url] ? nu are mutle pluginuri, are cam totul ce merita integrat in el. Updaturi rare si putine buguri. De securitate nu stiu.

  16. Sirg 13/01/2010 at 10:04 am #

    Eu nu fac update decat dupa o vreme, daca nu apare feedback negativ de la comunitate. Ca acum :) O vorba inginereasca spune: daca un lucru merge, nu-l repara. Daca update-ul e necesar il fac, daca nu, mai astept si evit complicatiile.

  17. Cypress 13/01/2010 at 5:39 pm #

    Joomla mah! :))

  18. Alakon 13/01/2010 at 5:51 pm #

    Siropele, nu-ti pune Joomla, ala e pt. site-uri serioase. =))

    Sincer, daca mi-as face “glob” d-asta (nevah!) mi-as instala Movable Type. Si gata. :))

  19. varadi.peter 18/01/2010 at 2:25 am #

    @cti97: how about Z-Blog? :D
    http://download.rainbowsoft.org/

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.