Gramatica in IT

Niste caractere uitate sau puse in plus in IT creeaza mult mai multe probleme decat niste caractere intr-un articol din ziar.

De exemplu, cei de la WordPress au reusit sa buseasca toata seria 2.8 si nu bine lanseaza o versiune ca deja trebuie sa iasa un hotfix pentru ea. Nu e bun 2.8? Nici o problema! Anuntam ca lansam 2.9! Nu conteaza compatibilitatea cu pluginurile si securitatea! Noi mergem inainte! Sa aiba prostii ce upgrada si repara in fiecare zi pentru ca wordpress au maimute pe post de programatori. Alternative?

Conteaza ca alt script foarte folosit are o vulnerabilitate sql veche de o luna? Neah!

Intre timp mai avem o vulnerabilitate BIND, o posibila vulnerabilitate SSH, un Firefox nou si o multime de oameni care nu inteleg de ce trebuie sa-si faca update la softuri / scripturi dar care plang in momentul cand sunt sparti.

Eu plang pentru ca sunt paranoic si patit. Trebuie sa fiu atent la toate si sa fac update la toate!

About Laurentiu

LVL 29 Internet midget. Freelancer. Am inceput acest blog in Februarie 2006. Din prima linie, garda veche, oldschool, alea alea... Imi place IT-ul, iubesc berea si open-source-ul.

,

15 Responses to Gramatica in IT

  1. L3ST August 5, 2009 at 12:33 pm #

    Daca esti hardcore si vrei sa eviti update-urile poti foarte usor sa modifici din fisierele codului doar ce te intereseza pe tine. Astfel eviti incompatibilitatile.
    Gandeste-te ca platforma asta este una din cele mai folosite open-source, iar comunitatea creata este una stransa.
    Citeam un articol ieri in care am primit cel mai bun exemplu: cel care descoperise vulnerabilitatea din 2.8.2 nu a publicat pe blog/site informatiile, ci le-a trimis direct la dev-team. Dev-team care face teste, dar nu poate fi niciodata sigur ca gata, asta e versiunea tata lor, cu asta ramanem.
    Pe de alta parte, update-urile ce tin de chestii noi trebuie facute pentru a fi in fata concurentei, sau pentru a nu fi depasiti de concurenta.

  2. Oradeanul August 5, 2009 at 12:35 pm #

    Nu ti se pare ca se intampla cam des updateurile astea de wordpress?

  3. PoloniculMov August 5, 2009 at 12:42 pm #

    Nu vreau sa fiu troll dar te plangi de un principiu de baza open-source: Release Early, Release Often.
    Cat despre WordPress stii doar ca nu vine cu garantie si ca nu au nici-o obligatie fata de tine sau de cei care fac plugin-uri.

  4. Oradeanul August 5, 2009 at 12:44 pm #

    Ma plang ca s-au inmultit releasurile. Parca am ceva mai bun de facut decat sa updatez wordpressuri in fiecare saptamana.
    2.7 a fost foarte bun si stabil. If it ain’t broke, why fix it?

  5. PoloniculMov August 5, 2009 at 12:50 pm #

    De ce ai updatat la 2.8?

  6. L3ST August 5, 2009 at 1:04 pm #

    Pai pastreaza rls-ul 2.7, cine nu te lasa? :)

    Si nu e vorba de broke aici, ci de “let’s make something shinier so we’ll still be #1″. Poti ramane usor pe o versiune de wordpress si sa scoti widget-ul cu update now.

  7. L3ST August 5, 2009 at 1:18 pm #

    Broken*, typo.

  8. Robintel August 5, 2009 at 1:21 pm #

    Cu Joomla! este un pic mai bine. La 8 zile după versiunea 1.5.13 s-a lansat 1.5.14, că au uitat băieţii să bage nişte linii de cod cu posibile efecte nasoale… :))

    Oricum, toate CMS-urile sunt cam la fel…

  9. Oradeanul August 5, 2009 at 1:51 pm #

    L3ST, n-ai cum sa-l pastrezi, e vulnerabil :)

  10. Jan August 5, 2009 at 2:31 pm #

    primesti ceva gratis, faci bani din astea si te plangi. not cool.
    de asta exista in lume si solutii software comerciale (nu neaparat mai bune).

  11. PoloniculMov August 5, 2009 at 2:57 pm #

    Pai release cycle-ul WordPress este cunoscut. Intamplator, faptul ca nu se ofera suport si update-uri pentru versiunile mai vechi il fac imposibil de folosit in productie :)

  12. Oradeanul August 5, 2009 at 2:59 pm #

    De asta e open source, ca sa pot sa urlu sa-l faca mai bine.
    Asta e contributia mea :)
    Daca e gratis nu se poate critica?

  13. Jan August 6, 2009 at 2:41 pm #

    Se poate critica, dar ca si provider de serviciu free ma simt insultat de cate ori se critica aiurea (90% din cazuri) sau avem useri efectiv revoltati ca nu au mai stiu eu ce feature custom.

  14. Satu Mare August 13, 2009 at 10:53 pm #

    Din cauza ca sistemul are inca, clar, vulnerabilitati, e nevoie de update-uri. Dupa ce repara una, apare alta. Si iar update. Si tot asa :))

  15. littl3l0rd August 25, 2009 at 10:04 am #

    Ok guys. Sunt de acord ca e gratuit si ca nu au nici obligatii (si nici responsabilitati), dar un lucru este clar si ei trebuie sa sustina proiectele din ceva. Deci din nou e vorba despre bani. Asa ca raspunsul la intrebarea DE CE ?! DE CE ?! DE CE ?! De ce aia de ce cealalta ? Este simpla. PURE MARKETING ! Marketing strica tot! “Money makes the world go around…”